absolinux

Aller à la page : 1 2 suivante

Sujet : problème de lecteur sous kubuntu
posté par sqrt 18 messages     le  30-06-2007  à  19:59citer
bonsoir,

je suis sous kubuntu 7.04 et j'ai un problème avec mes lecteurs.

je dispose d'un lecteur dvd et cd rom (celui la aucun problème) et d'un lecteur graveur cd rom (avec lui des problèmes). En fait quand j'insérais un cd, le système ne le détecte pas....

voilà j'ai changé mon fstab et le système détecte le cd qu'après redémarrage et encore quand j'ai voulu ensuite graver, à la moitié de la procédure ca m'affichait: no medium present....

voilà mon fstab initial:
# /etc/fstab: static file system information.
#
#             
proc /proc proc defaults 0 0
# /dev/sda1
UUID=e0857797-2a37-4576-8647-17f7e3bd9c0a / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
# /dev/sda5
UUID=60d258ea-1708-4cf9-bd2d-19fc8095e215 none swap sw 0 0
/dev/scd0 /media/cdrom0 auto user,atime,auto,rw,dev,exec,suid 0 0
/dev/scd0 /media/cdrom0 auto users,atime,auto,rw,dev,exec,suid 0 0
/dev/fd0 /media/floppy0 auto user,atime,noauto,rw,dev,exec,suid 0 0
/dev/scd1  auto user,atime,noauto,rw,nodev,noexec,nosuid 0 0

ensuite on m' a dit de changer:

ca:

/dev/scd0 /media/cdrom0 auto user,atime,auto,rw,dev,exec,suid 0 0

par ça

/dev/scd0 /media/cdrom0 iso9660 user,atime,auto,rw,dev,exec,suid 0 0

et je rencontre le problème...

que dois je faire,

merci :)
posté par Texou 271 messages     le  30-06-2007  à  20:07citer
Bonjour et bienvenue sur absolinux.

Je n'arrive pas à  comprendre exactement ce qu'il se passe sur ta machine. Donc on va déjà mettre les choses à plat:
Tu as donc un lecteur scd0 vlecteur) et scd1 (graveur) n'est-ce pas? Ce sont 2 lecteurs SATA?
Par ailleurs, que  se passe-t-il quand tu mets un CD de données et que tu fais:
mount -t iso6660  /dev/scd0 /media/cdrom (ou /media/cequetuveux)OE

Lit-il? ou non?
Autre test: installe lshw sur ton système, exécute-le et cherche ce qu'il raconte sur l lecteur CD. Pour cela, observe s'il détecte bien DOUX lecteurs. Sinon c'est qu'il voit pas l'un des 2.

Tiens-nous au courant. On essaiera d'avancer munis de ces précisions et du résultat de ces tests.

++ Texou

_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par sqrt 18 messages     le  30-06-2007  à  20:13citer
en on va laisser le lecteur dvd rom qui fonctionne bien.

En revanche je possède un autre lecteur (aussi graveur) de cd rom qui ne lit pas (je l'insére et rien ne se passait avant mes modifications).

de plus si je vais dans système settings pour voir mes lecteurs, les 2 sont désactivés...

je vais essyer les commandes....

[smile]

merci
posté par Texou 271 messages     le  30-06-2007  à  20:16citer
Oui encas de problèmes la ligne de commande est plus fiable. Tente donc un mount -tiso9660 /dev/scj0 /media/xxx et un lshw (cf. message ci-dessus).
Bon courage ettiens-nous au courant. ++
_______________________

Texou
Coadministrateur du projet absolinux
Président de l'association traduc.org
Coordinateur du projet Linux From Scratch
Coordinateur au sein du projet Trad GNU de l'April
Animateur suppléant du groupe de travail Accessibilité de l'April
posté par TrueDD 97 messages     le  02-07-2007  à  12:03citer
sqrt a dit :
voilà mon fstab initial:
# /etc/fstab: static file system information.
#
#             
proc /proc proc defaults 0 0
# /dev/sda1
UUID=e0857797-2a37-4576-8647-17f7e3bd9c0a / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
# /dev/sda5
UUID=60d258ea-1708-4cf9-bd2d-19fc8095e215 none swap sw 0 0
/dev/scd0 /media/cdrom0 auto user,atime,auto,rw,dev,exec,suid 0 0
/dev/scd0 /media/cdrom0 auto users,atime,auto,rw,dev,exec,suid 0 0
/dev/fd0 /media/floppy0 auto user,atime,noauto,rw,dev,exec,suid 0 0
/dev/scd1  auto user,atime,noauto,rw,nodev,noexec,nosuid 0 0



La ligne concernant le device /dev/scd1 m'intrigue un peu. Tu n'as défini aucun point de montage. Est-ce celui qui correspond à ton graveur ?

D'autre part, il y a deux lignes qui font référence au device /dev/scd0. l'un avec user et l'autre avec users ... !?. Supprimes-en une des deux.
_______________________

Retrouvez-nous sur le canal #absolinux (serveur irc.freenode.net) [smile]
posté par Skippythekangoo 102 messages     le  02-07-2007  à  15:23citer
c'est a peu prés ce que je lui ai dit sur un autre forum, et sur une room via je ne sais plus qui (FenDanT, je crois...:) )

Sinon, bienvenue sur Absolinux.net
_______________________

º¿º Skippy the Kangoo º¿º
posté par sqrt 18 messages     le  15-07-2007  à  21:18citer
oui ok j'essaie de supprimer users
posté par TrueDD 97 messages     le  15-07-2007  à  22:14citer
ben disons que ces deux lignes font un peu double-emploi, et que tu devrais n'en laisser qu'une mais je ne pense pas qu'elles soient la source de ton problème.

par contre, je n'en dirais pas autant du fait que tu n'aie définis aucun point de montage pour /dev/scd1.
_______________________

Retrouvez-nous sur le canal #absolinux (serveur irc.freenode.net) [smile]
posté par sqrt 18 messages     le  17-07-2007  à  15:08citer
bonjour,

alors comment on définit un poitn de montage

posté par TrueDD 97 messages     le  17-07-2007  à  16:07citer
Toujours dans le fichier /etc/fstab, il te suffit d'ajouter en paramètre de la ligne concernant le device /dev/scd1 le chemin vers un répertoire vide que tu auras créé à cette fin. (par ex. /media/cdrec ou /media/cdrom1)

par exemple, pour le device /dev/scd0 le point de montage est bien défini et correspond au répertoire /media/cdrom0 (cf. fstab)

/dev/scd0 /media/cdrom0 auto users,atime,auto,rw,dev,exec,suid 0 0



donc la ligne concernant /dev/scd1 devrait ressembler à ceci :

/dev/scd1 /media/cdrec auto user,atime,noauto,rw,nodev,noexec,nosuid 0 0


_______________________

Retrouvez-nous sur le canal #absolinux (serveur irc.freenode.net) [smile]


Aller à la page : 1 2 suivante

http://med4treat.top