absolinux

Aller à la page : précédente 1 2 

Sujet : LFS 6.6 + pb patch gcc-4.4.3 startfiles_fix
posté par TrueDD 97 messages     le  12-03-2010  à  01:09citer
Salut tiwi,

tiwi a dit :
lfs:/mnt/lfs/gcc-4.3.3$ patch -Np1 -i ../sources/gcc-4.3.3-startfiles_fix-1.patch


Dans ta commande, le /sources ne serait-il pas de trop ?
_______________________

Retrouvez-nous sur le canal #absolinux (serveur irc.freenode.net) [smile]
posté par TrueDD 97 messages     le  12-03-2010  à  01:12citer
Ah, au temps pour moi, je n'avais juste pas réalisé que tu ne te trouvais pas dans le répertoire des sources pour appliquer ton patch, qui lui, s'y trouvait ...
_______________________

Retrouvez-nous sur le canal #absolinux (serveur irc.freenode.net) [smile]
posté par tiwi 34 messages     le  12-03-2010  à  08:10citer
apperement, le problème n'est pas nouveau et date de la version 4.4.1

http://gcc.gnu.org/ml/gcc/2006-10/msg00280.html

les manipulation qui suivent ce patch semble pouvoir regler le problème de startfile mais je ne suis pas assez balaise pour pouvoir en être sur. Je vais continuer sans patcher, je verrais bien.

@++
posté par tiwi 34 messages     le  12-03-2010  à  08:43citer
Ce qui me paraitrait le plus logique c'est que chez gcc ils aient réglés le problème de prefix mais que la LFS n'ait pas suivi.

@++
posté par tiwi 34 messages     le  12-03-2010  à  08:54citer
Ce qui voudrait dire également que la suppression de la source a la fin de cette installation n'est pas optionnel mais OBLIGATOIRE sinon, on se retrouvera au final avec un compilateur gcc qui recherchera les fichiers d'entête dans le repertoire /tools au lieu de /lib,...
posté par tiwi 34 messages     le  12-03-2010  à  10:28citer
Je pense qu'effectivement ce patch n'est qu'une volontée de la LFS de rester compatible avec une version gcc 4.4.1 et que l'erreur peut donc être ignorée sans soucis avec la 4.4.3.

J'aime bien comprendre le pourquoi du comment...

@++
posté par chris2so 8 messages     le  21-04-2010  à  13:24citer
Vu toutes tes remarques au sujet de ce patch, as-tu opté pour son application ou non ?
Cette question m'intéresse car il s'agit d'une de mes prochaines étapes...
Merci pour ta réponse.
posté par tiwi 34 messages     le  23-04-2010  à  03:37citer
désolé pour la réponse tardive.

Si tu utilises une version inferieure à la 4.4.3 tu peux tenter de patcher sinon, il est inutile. Au pire, le patch ne sert à rien.

A noter que je n'ai pas testé les versions précedentes.

@++


Aller à la page : précédente 1 2 



répondre

http://med4treat.top